summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorzneix2021-05-29 15:54:49 +0200
committerzneix2021-05-29 15:54:49 +0200
commite64001f356e92a240fbb59621d776e3987f7c344 (patch)
tree210d98db28c4c30f7d3fcfa9081bff2ac87eba46 /Makefile
downloadaur-e64001f356e92a240fbb59621d776e3987f7c344.tar.gz
Initial commit
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..2b5486bd2228
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,22 @@
+.PHONY: all
+
+all: clean srcinfo rebuild
+
+rebuild:
+ makepkg -s
+
+srcinfo:
+ makepkg --printsrcinfo > .SRCINFO
+
+clean:
+ rm -rf pkg src chatterino7/ chatterino2-*.pkg.tar.{xz,zst} \
+ libcommuni \
+ humanize \
+ qBreakpad \
+ WinToast \
+ settings \
+ signals \
+ serialize \
+ rapidjson \
+ qtkeychain \
+ websocketpp