summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorTrevor Bramble2018-06-13 22:11:56 -0700
committerTrevor Bramble2018-06-13 22:11:56 -0700
commit5b10fbd7d3bcd57f271f678528e9863e3aa6b579 (patch)
tree05090de013a7480ffbbd8c8039d859f477f4dcfa /Makefile
downloadaur-5b10fbd7d3bcd57f271f678528e9863e3aa6b579.tar.gz
0.1.133
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..1035977843b1
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,14 @@
+default: build
+
+build: namcap
+ makepkg
+ mksrcinfo
+
+namcap:
+ namcap PKGBUILD
+
+# too many failures we can't correct due to PKGBUILD design
+shellcheck:
+ shellcheck PKGBUILD
+
+vet: namcap shellcheck