summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorKrzysztof AS (3ED)2020-05-28 18:24:37 +0200
committerKrzysztof AS (3ED)2020-05-28 18:24:37 +0200
commit1d9e881cd536df983eec9ef93c6a024b03faa5ef (patch)
tree0c0f3a2d4ed44f4cfdbe7c27dd6eaf53cad7e15e /Makefile
parent9e2aba2df76adfd8dee1f6a41c85d914eec789f9 (diff)
downloadaur-deadbeef-plugin-rating.tar.gz
added: deadbeef.h path patch, Makefile
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..5bc0b472fe40
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,16 @@
+CFLAGS_EXTRA ?= -Wall -fPIC -std=c99 -shared -O2
+PREFIX ?= $(HOME)/.local
+LIBDIR ?= /lib/deadbeef
+
+build:
+ $(CC) $(CFLAGS) $(CFLAGS_EXTRA) rating.c -o rating.so
+
+clean:
+ test -f rating.so && rm rating.so || true
+
+install:
+ install -d "$(DESTDIR)$(PREFIX)$(LIBDIR)"
+ install "rating.so" "$(DESTDIR)$(PREFIX)$(LIBDIR)/rating.so"
+
+uninstall:
+ rm "$(DESTDIR)$(PREFIX)$(LIBDIR)/rating.so"