summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorNicolas Karolak2022-10-29 13:18:52 +0200
committerNicolas Karolak2022-10-29 13:18:52 +0200
commit2b9a28b9eed0ce7b7b32e888f41ec756dae2950c (patch)
treebf56f04e3bb45465f815def54a0896d47550ce11 /Makefile
parent26ab0985098fcd8a028d69171b6b27b1bd17738c (diff)
downloadaur-2b9a28b9eed0ce7b7b32e888f41ec756dae2950c.tar.gz
update version
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..b65a8998766d
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,37 @@
+.PHONY: all
+all:
+
+.PHONY: build
+## build: Build package
+build:
+ @echo "Building..."
+ @makepkg --syncdeps --rmdeps
+
+.PHONY: install
+## install: Install package
+install:
+ @echo "Installing..."
+ @makepkg --syncdeps --install --rmdeps
+
+.PHONY: sum
+## sum: Generate sums
+sum:
+ @makepkg --geninteg
+
+.PHONY: srcinfo
+## srcinfo: Update the .SRCINFO file
+srcinfo:
+ @echo "Updating srcinfo..."
+ @makepkg --printsrcinfo >| .SRCINFO
+
+.PHONY: clean
+## clean: Clean up build artifacts
+clean:
+ @echo "Cleaning..."
+ @rm -rf devc-* pkg/ src/
+
+.PHONY: help
+## help: Prints this help message
+help:
+ @echo -e "Usage: \n"
+ @sed -n 's/^##//p' ${MAKEFILE_LIST} | column -t -s ':' | sed -e 's/^/ /'