aboutsummarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorAnselm R. Garbe2006-07-10 16:38:18 +0200
committerAnselm R. Garbe2006-07-10 16:38:18 +0200
commitcfec1712557f8a45e43e7784e6d0413f80fe8298 (patch)
tree5989d6018cb7f42a3e6b950571148e015730f7ac /Makefile
downloadaur-cfec1712557f8a45e43e7784e6d0413f80fe8298.tar.gz
initial import
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..fff5ee1ef993
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,23 @@
+# gridwm - grid window manager
+# (C)opyright MMVI Anselm R. Garbe
+
+include config.mk
+
+SRC = wm.c
+OBJ = ${SRC:.c=.o}
+
+all: gridwm
+ @echo finished
+
+.c.o:
+ @echo CC $<
+ @${CC} -c ${CFLAGS} $<
+
+${OBJ}: wm.h
+
+gridwm: ${OBJ}
+ @echo LD $@
+ @${CC} -o $@ ${OBJ} ${X11LDFLAGS}
+
+clean:
+ rm -f gridwm *.o