summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorgituser2021-05-29 13:25:07 +0200
committergituser2021-05-29 13:41:20 +0200
commit3129ee0c74c339757b09ed46369a741185606d2a (patch)
tree99b2caa129b9a95e66a1b7e14ea753b2978fb3ab /Makefile
downloadaur-3129ee0c74c339757b09ed46369a741185606d2a.tar.gz
GPD Win3 Goodix dkms module
Diffstat (limited to 'Makefile')
-rwxr-xr-xMakefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100755
index 000000000000..8a9cea6e2ca4
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,21 @@
+DRIVER_NAME := goodix
+KERNEL_SOURCE_DIR ?= /lib/modules/`uname -r`/build
+
+EXTRA_CFLAGS +=
+
+obj-m := $(DRIVER_NAME).o
+
+#DRIVER_FILES := goodix.o
+
+#$(DRIVER_NAME)-objs:= $(DRIVER_FILES)
+
+modules:
+ $(MAKE) -C $(KERNEL_SOURCE_DIR) KCPPFLAGS="$(EXTRA_CFLAGS)" M=$(PWD) modules
+
+modules_install:
+ $(MAKE) -C $(KERNEL_SOURCE_DIR) M=$(PWD) modules_install
+
+install: modules_install
+
+clean:
+ $(MAKE) -C $(KERNEL_SOURCE_DIR) M=$(PWD) clean