summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorNicolas Guilloux2019-10-07 21:40:13 +0200
committerNicolas Guilloux2019-10-07 21:40:13 +0200
commitb44b3c051e4d493c0e8b6d6de4529f5ade7c2eb9 (patch)
tree77fe529d30d3040df59256b259aaf58adc113417 /Makefile
downloadaur-b44b3c051e4d493c0e8b6d6de4529f5ade7c2eb9.tar.gz
Version 1.1.1
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..f4a1faabe6eb
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,23 @@
+version = 9add3366d25530d51d168608c54b5339b64d2a4e
+
+help:
+ @grep -E '(^[a-zA-Z_-]+:.*?##.*$$)|(^##)' $(MAKEFILE_LIST) | awk 'BEGIN {FS = ":.*?## "}; {printf "\033[32m%-10s\033[0m %s\n", $$1, $$2}' | sed -e 's/\[32m##/[33m/'
+
+build:clear ## Build pakage
+ makepkg -s
+
+clear: ## Clear files
+ rm -rf ./pkg
+ rm -rf ./src
+ rm -f ./*.zip
+ rm -f ./*~
+ rm -f ./kget-integrator*
+
+pkgsum: ## update pkgsum with updpkgsums
+ updpkgsums
+
+release:clear pkgsum srcinfo ## Release preparation
+ git pull
+
+srcinfo: ## génération .SRCINFO
+ makepkg --printsrcinfo > .SRCINFO