summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorfabrixxm2022-08-05 11:11:48 +0200
committerfabrixxm2022-08-05 11:11:48 +0200
commitcf956d64737e9ab620ac00611f5eee701a40cfeb (patch)
tree93960370d999fccb17cef756f4f0b4ed7ddd14ea /Makefile
parent8328523832e720ad46c39a7e42e6862cb9bfa643 (diff)
downloadaur-cf956d64737e9ab620ac00611f5eee701a40cfeb.tar.gz
add hazwaz, arcomplete and gitpython as optional, 'any' arch
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..bdfd498f482e
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,21 @@
+.PHONY: all build push clean
+
+all: .SRCINFO
+ git add PKGBUILD .SRCINFO
+
+.SRCINFO: PKGBUILD
+ namcap PKGBUILD
+ makepkg --printsrcinfo > .SRCINFO
+
+build:
+ makepkg -f
+ namcap *.pkg.tar.zst
+
+push: build .SRCINFO
+ git add PKGBUILD .SRCINFO
+ git commit
+ git push
+
+clean:
+ rm -f *.pkg.tar.zst
+ rm -fr pkg src