summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorGötz Christ2020-04-23 11:35:00 -0500
committerGötz Christ2020-04-23 11:40:23 -0500
commit0227b73b0300c5b9f48a4b6667df8739c0ca93a7 (patch)
tree9394ba9859d1def21c16d375e8ef0cd2b7006fc3 /Makefile
parent852866fd44f04923b88ad151954eaf904c5b9c4d (diff)
downloadaur-0227b73b0300c5b9f48a4b6667df8739c0ca93a7.tar.gz
Update to 2.95.5
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..ebad14049f07
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,27 @@
+all: clean build git install
+
+clean:
+ rm -r src pkg
+
+geninteg:
+ makepkg --geninteg >> PKGBUILD
+
+srcinfo:
+ makepkg --printsrcinfo > .SRCINFO
+
+makepkg:
+ makepkg -s
+
+build: geninteg srcinfo makepkg
+
+git: git_add git_commit
+
+git_add:
+ git add PKGBUILD .SRCINFO
+
+git_commit: VERSION = $(shell grep pkgver .SRCINFO | cut -d '=' -f 2 | tr -d '[:space:]')
+git_commit:
+ git commit -m "Update to ${VERSION}"
+
+install:
+ makepkg --install