summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorAlex Hirzel2022-06-02 20:36:14 -0400
committerAlex Hirzel2022-06-02 22:18:03 -0400
commit6b63edfec01b7e51288fbcda74b43a3fd83d1417 (patch)
treeaf79bbdadd415baaec7eb4dfcd55259d37e268c1 /Makefile
parenta4ae05e6635b4e01d07281c0bcd2efa6c3626365 (diff)
downloadaur-6b63edfec01b7e51288fbcda74b43a3fd83d1417.tar.gz
add .gitignore, check(), test and Makefile; bump pkgrel
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..7c74715b5fa5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,27 @@
+MAKEFLAGS += --no-builtin-rules
+OUTPUT = $(shell bash -c 'source PKGBUILD && echo mitsuba2-git-$pkgver-$pkgrel-x86_64.pkg.tar.zst')
+
+PKGREL = $(shell bash -c 'source PKGBUILD && echo $pkgver')
+
+.PHONY: check help clean distclean
+.DEFAULT: help
+
+check:: .SRCINFO
+
+help:: ## show this help text
+ @egrep -h '\s##\s' $(MAKEFILE_LIST) | sort | awk 'BEGIN {FS = ":.*?## "}; {printf " %-13s - %s\n", $$1, $$2}'
+
+clean:: ## remove files associated with this build
+ rm -rf pkg src
+
+distclean:: clean ## remove all downloaded and built files
+ rm -f mitsuba2-git-*-x86_64.pkg.tar.zst
+ rm -rf asmjit enoki mitsuba-data mitsuba2 openexr tbb tinyformat
+
+.SRCINFO: PKGBUILD ## update the .SRCINFO file
+ makepkg --printsrcinfo > $@
+
+build: ${OUTPUT} ## build package
+
+${OUTPUT}: PKGBUILD
+ makepkg -sf