summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorGeorge Rawlinson2022-10-28 12:14:41 +1300
committerGeorge Rawlinson2022-10-28 12:14:41 +1300
commit193ad5c1adec470a60e688cc0544047a942bc591 (patch)
tree5fbd8510079dbff6af8377b57b0bd48d6b57c304 /Makefile
downloadaur-193ad5c1adec470a60e688cc0544047a942bc591.tar.gz
addpkg: motu r19-1
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..1cbc84e18ed3
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,9 @@
+# https://www.kernel.org/doc/Documentation/kbuild/modules.txt
+
+obj-m := motu.o
+
+UNAME_R ?= $(shell uname -r)
+KDIR ?= /lib/modules/$(UNAME_R)/build
+
+all:
+ $(MAKE) -C $(KDIR) M=$(shell pwd)