summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorStefan Springer2018-11-23 00:25:43 +0100
committerStefan Springer2018-11-23 00:25:43 +0100
commit4d49388d37f7fe54578bd23a417316a9c89ed9ac (patch)
treebe5dd6359505b03ad6a39e8b83f2461def9b54e6 /Makefile
downloadaur-4d49388d37f7fe54578bd23a417316a9c89ed9ac.tar.gz
Port nvidia-bl to DKMS, fix kernel warning about unsupported backlight type
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..4c16ce156860
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,15 @@
+NAME=nvidia-bl
+MODULE_NAME=nvidia_bl
+VERSION=0.17.3
+
+obj-m := $(MODULE_NAME).o
+KVER := $(shell uname -r)
+
+KDIR := /usr/lib/modules/$(KVER)/build
+PWD := $(shell pwd)
+
+default:
+ $(MAKE) -C $(KDIR) SUBDIRS=$(PWD) modules
+
+clean:
+ $(MAKE) -C $(KDIR) SUBDIRS=$(PWD) clean