aboutsummarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorSebastian Wiesner2023-02-26 10:23:46 +0100
committerSebastian Wiesner2023-02-26 10:34:57 +0100
commitfee7df2c64724ce51e58abd9bc765c6d67ba9216 (patch)
tree4cccd6bf76709a2de5b93e810f9245438e089497 /Makefile
downloadaur-fee7df2c64724ce51e58abd9bc765c6d67ba9216.tar.gz
Initial commit
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..1dada5096d36
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,22 @@
+PREFIX = /usr
+DESTDIR =
+
+HOOK_SRC = 99-check-reproducible-status.hook
+SCRIPT_SRC = check-reproducible-status
+
+INSTALL = install
+MAKEPKG = makepkg
+SHA256SUM = sha256sum
+
+.PHONY: install
+install:
+ $(INSTALL) -Dm644 -t $(DESTDIR)/$(PREFIX)/share/libalpm/hooks $(HOOK_SRC)
+ $(INSTALL) -Dm755 -t $(DESTDIR)/$(PREFIX)/share/libalpm/scripts $(SCRIPT_SRC)
+
+.SRCINFO: PKGBUILD
+ $(MAKEPKG) --printsrcinfo > .SRCINFO
+
+.PHONY: verify
+verify:
+ $(MAKEPKG) --verifysource
+