summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorTomasz Jakub Rup2020-04-20 07:33:49 +0200
committerTomasz Jakub Rup2020-04-20 07:33:49 +0200
commitc5f50e75634c8fc180d01f9804e5154cb7fba585 (patch)
treec357d2c0355df59c6bc925b18990d315d8b466ef /Makefile
parentaa50187bb80204a637b78ecb35d1d895998e0924 (diff)
downloadaur-c5f50e75634c8fc180d01f9804e5154cb7fba585.tar.gz
improve build process
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 2afef507a4b0..5af9642aba0a 100644
--- a/Makefile
+++ b/Makefile
@@ -1,5 +1,5 @@
all:
- make srcinfo
+ make prepare
make build
make clean
make check
@@ -7,7 +7,8 @@ all:
build:
makepkg -f
-srcinfo:
+prepare:
+ sed -ie "s|md5sums.*|`makepkg -g 2>&1|grep md5sums`|g" PKGBUILD
makepkg --printsrcinfo > .SRCINFO
clean: