summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorMark Blakeney2019-05-21 09:35:58 +1000
committerMark Blakeney2019-05-21 09:39:14 +1000
commitc505ed649c91fbb224d52490e5bb8243bb75fa94 (patch)
treee36724374bec3734ab157b1db5a5eca4927fabec /Makefile
parentfaa4f0c50e76cc7bba219f47fe02fe148311c654 (diff)
downloadaur-c505ed649c91fbb224d52490e5bb8243bb75fa94.tar.gz
Relative paths should be allowed
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..d98ad5acca65
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,23 @@
+nam = $(shell sed -n 's/^pkgname=//p' PKGBUILD)
+src = PKGBUILD
+inf = .SRCINFO
+pkg = $(shell ls -v $(nam)*.pkg.tar* 2>/dev/null | tail -1)
+
+all: sum $(inf) check
+
+$(inf): $(src)
+ makepkg --printsrcinfo >$@
+
+check: $(src)
+ namcap $^
+ifneq ($(strip $(pkg)),)
+ namcap $(pkg)
+endif
+
+sum: $(src)
+ updpkgsums
+
+clean:
+ rm -rf $(inf) $(nam)-* *.tar.xz *.tar.gz pkg/ src/ *.part
+
+# vim: se ts=4: