summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorAnton Leontiev2016-01-25 17:08:24 +0300
committerAnton Leontiev2016-01-25 17:08:24 +0300
commit64c57868dce359d4bbaec0dca3264deddfac097c (patch)
tree1a8d99f5d38c64f5c55dee77a735d31e689a6577 /Makefile
downloadaur-64c57868dce359d4bbaec0dca3264deddfac097c.tar.gz
Initial v2.6.0-1
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..d418b19fa696
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,18 @@
+SOURCES := ramspeed.c
+
+ifeq ($(CARCH),i686)
+SOURCES += $(wildcard i386/*.s) $(wildcard i386/cpuinfo/*.s)
+CPPFLAGS += -DI386_ASM
+else ifeq ($(CARCH),x86_64)
+SOURCES += $(wildcard amd64/*.s)
+CPPFLAGS += -DAMD64_ASM
+else
+SOURCES += fltmem.c intmem.c fltmark.c intmark.c
+endif
+
+ramspeed: $(SOURCES)
+ echo $(CARCH)
+ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) $^ -o $@
+
+clean:
+ rm -f *.o ramspeed