summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorAlexandre Macabies2018-03-04 21:45:04 +0100
committerAlexandre Macabies2018-03-04 21:45:04 +0100
commit30c0a10dc27967c3eabcddc92ee21f58e56c81f4 (patch)
tree59f681e3e0973dc159e742f268b73795ed1804d7 /Makefile
downloadaur-30c0a10dc27967c3eabcddc92ee21f58e56c81f4.tar.gz
Initial commit
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..c4d24c4120ab
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,21 @@
+PY = rofi-twitch
+ICON = $(PY).png
+DESKTOP = $(PY).desktop
+
+pkg: .SRCINFO
+ makepkg --check --noconfirm -sf
+
+.SRCINFO: PKGBUILD
+ makepkg --check --printsrcinfo > $@
+
+PKGBUILD: format pngopt $(DESKTOP)
+ updpkgsums
+
+format: $(PY)
+ yapf -i $<
+
+pngopt: $(ICON)
+ optipng $<
+
+.PHONY: format pngopt
+.PRECIOUS: $(PY) $(ICON) $(DESKTOP) PKGBUILD