aboutsummarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorNicolas Guilloux2019-10-08 21:46:59 +0200
committerNicolas Guilloux2019-10-08 21:46:59 +0200
commit1603403bef1ee9e9a6203fedad8c36da46f6eeea (patch)
tree6ec35228bb55ec7765f598354f038c905c3a86d1 /Makefile
parent427dfbc4fe62b5ae4c391185beebf211e06e278f (diff)
downloadaur-1603403bef1ee9e9a6203fedad8c36da46f6eeea.tar.gz
Improve PKGBUILD
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index 4633904db0be..198e444982d6 100644
--- a/Makefile
+++ b/Makefile
@@ -3,10 +3,10 @@ version = 9add3366d25530d51d168608c54b5339b64d2a4e
help:
@grep -E '(^[a-zA-Z_-]+:.*?##.*$$)|(^##)' $(MAKEFILE_LIST) | awk 'BEGIN {FS = ":.*?## "}; {printf "\033[32m%-10s\033[0m %s\n", $$1, $$2}' | sed -e 's/\[32m##/[33m/'
-build:clear ## Build pakage
+build:clear ## Builds pakage
makepkg -s
-clear: ## Clear files
+clear: ## Clears files
rm -rf ./pkg
rm -rf ./src
rm -f ./*.deb
@@ -16,10 +16,10 @@ clear: ## Clear files
rm -f ./*~
rm -f shadow-beta.zip
-install:build ## Install package with pacman
+install:build ## Installs package with pacman
sudo pacman -U shadow-beta-*.pkg.tar
-pkgsum: ## update pkgsum with updpkgsums
+pkgsum: ## Updates pkgsum with updpkgsums
updpkgsums
recup: ## Get git files
@@ -30,8 +30,8 @@ recup: ## Get git files
release:clear pkgsum srcinfo ## Release preparation
git pull
-sanity: ## Checking package sanity
+sanity: ## Checkcwqing package sanity
namcap shadow-beta-*.pkg.tar
-srcinfo: ## génération .SRCINFO
+srcinfo: ## Generates .SRCINFO
makepkg --printsrcinfo > .SRCINFO