aboutsummarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authoragentcobra2019-05-01 15:40:05 +0200
committeragentcobra2019-05-01 15:40:05 +0200
commit54e12c6b249fc7c990cddc03db8360da9e2c77e4 (patch)
treebe7ab13a3bff23e33deafcc0eb2893ae96ca72a1 /Makefile
parentae4246ff63381881c05cc93353e2b0583cc3b644 (diff)
downloadaur-54e12c6b249fc7c990cddc03db8360da9e2c77e4.tar.gz
sync aur on github
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile19
1 files changed, 17 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 4a30a06cfe22..ad9bddc46663 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,6 @@
-help:
+version = 9add3366d25530d51d168608c54b5339b64d2a4e
+
+help:
@grep -E '(^[a-zA-Z_-]+:.*?##.*$$)|(^##)' $(MAKEFILE_LIST) | awk 'BEGIN {FS = ":.*?## "}; {printf "\033[32m%-10s\033[0m %s\n", $$1, $$2}' | sed -e 's/\[32m##/[33m/'
build:clear ## Build pakage
@@ -7,9 +9,11 @@ build:clear ## Build pakage
clear: ## Clear files
rm -rf ./pkg
rm -rf ./src
- rm -f ./shadowbeta.deb
+ rm -f ./*.deb
rm -f ./shadow-beta-*.pkg.tar
+ rm -f ./shadow-beta-*.pkg.tar.xz
rm -f ./*~
+ rm -f shadow-beta.zip
install:build ## Install package with pacman
sudo pacman -U shadow-beta-*.pkg.tar
@@ -17,5 +21,16 @@ install:build ## Install package with pacman
pkgsum: ## update pkgsum with updpkgsums
updpkgsums
+recup: ## Get git files
+ wget -O INSTALL https://raw.githubusercontent.com/NicolasGuilloux/blade-shadow-beta/master/Arch/AUR/INSTALL
+ wget -O wrapper.pl https://raw.githubusercontent.com/NicolasGuilloux/blade-shadow-beta/master/AppImage/wrapper.pl
+ wget -O report.pl https://raw.githubusercontent.com/NicolasGuilloux/blade-shadow-beta/master/AppImage/report.pl
+
+release:clear pkgsum srcinfo ## Release preparation
+ git pull
+
+sanity: ## Checking package sanity
+ namcap shadow-beta-*.pkg.tar
+
srcinfo: ## génération .SRCINFO
makepkg --printsrcinfo > .SRCINFO