summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorMark Blakeney2018-01-11 13:55:43 +1000
committerMark Blakeney2018-01-11 13:55:43 +1000
commit2205204c96365bd1ac1b9e53588f076dd08e5b36 (patch)
tree6f1a007c3de242d2666029d01d6b1abd8ea4d809 /Makefile
downloadaur-2205204c96365bd1ac1b9e53588f076dd08e5b36.tar.gz
Initial commit
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..539f0b4dfdc6
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,19 @@
+nam = $(shell sed -n 's/^_pkgname=//p' PKGBUILD)
+src = PKGBUILD
+inf = .SRCINFO
+
+all: sum $(inf) check
+
+$(inf): $(src)
+ makepkg --printsrcinfo >$@
+
+check: $(src)
+ namcap $^
+
+sum: $(src)
+ updpkgsums
+
+clean:
+ rm -rf $(inf) $(nam)-* *.tar.xz *.tar.gz pkg/ src/ *.part
+
+# vim: se ts=4: