aboutsummarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorHiltjo Posthuma2017-09-15 11:16:37 +0200
committerHiltjo Posthuma2017-09-15 11:16:37 +0200
commita0ccf90092b5e1a805223fc63c7ba442fac286ee (patch)
treeaa9b212b24217120dde4a3f34feee381b7985e7b /Makefile
parent56463b357e5f25903dae9537d60780bf78f9a542 (diff)
downloadaur-a0ccf90092b5e1a805223fc63c7ba442fac286ee.tar.gz
Revert "Revert "fixed STLDFLAG order in broken st Makefile""
This reverts commit 274d46ace00003d1df718b974d17642cbce167d5. Sorry, the original commit was correct after all. It allows has the correct link order and supports static-linking also. Just a reminder: it is important to give a (brief) rationale of the patch intentions.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 128ee9d406f5..c678ead14de9 100644
--- a/Makefile
+++ b/Makefile
@@ -27,7 +27,7 @@ x.o: arg.h st.h win.h
$(OBJ): config.h config.mk
st: $(OBJ)
- $(CC) $(STLDFLAGS) -o $@ $(OBJ)
+ $(CC) -o $@ $(OBJ) $(STLDFLAGS)
clean:
rm -f st $(OBJ) st-$(VERSION).tar.gz