summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorPhillip Schichtel2022-12-11 16:26:41 +0100
committerPhillip Schichtel2022-12-11 16:29:35 +0100
commite2666de55aa5ee1135badec12b506c003045a32d (patch)
tree2931c53968f966a516e71e40a288e20407991060 /Makefile
parent63ef4af1187d6c16269a810120d313256f51a148 (diff)
downloadaur-e2666de55aa5ee1135badec12b506c003045a32d.tar.gz
redo all the things
* include the bundled jre7 * drop the post-install script * move the state directory from .starsector to .local/share/starsector * add support for customizing jvm args by supplying a bash script at .config/starsector/statup.sj
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..059c9af31da3
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,12 @@
+
+.SRCINFO: PKGBUILD
+ makepkg --printsrcinfo > .SRCINFO
+
+package: PKGBUILD .SRCINFO
+ updpkgsums
+ makepkg --syncdeps --rmdeps --force --clean --noconfirm
+
+all: package
+
+clean:
+ rm -Rv .SRCINFO *.tar.* src/ pkg/ 2> /dev/null || true