summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDevaev Maxim2018-09-11 08:47:53 +0300
committerDevaev Maxim2018-09-11 08:47:53 +0300
commitb31a72426180f2360f004b4fe4b7a6ef033d96e8 (patch)
tree79f5bc3e5159486b269790e66290faed7b57eef2 /Makefile
downloadaur-b31a72426180f2360f004b4fe4b7a6ef033d96e8.tar.gz
Update to 0.1-1
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..21ab182ea0f5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,18 @@
+KVERSION ?= $(shell uname -r)
+
+SRC_URL = https://raw.githubusercontent.com/raspberrypi/linux/rpi-$(shell echo $(KVERSION) | grep -Po '\d\.\d+').y/drivers/media/i2c
+
+obj-m += tc358743.o
+
+all: tc358743_regs.h tc358743.c
+ make -C /lib/modules/$(KVERSION)/build M=$(PWD) modules
+
+clean:
+ make -C /lib/modules/$(KVERSION)/build M=$(PWD) clean
+ rm *.c *.h
+
+tc358743_regs.h:
+ wget $(SRC_URL)/tc358743_regs.h
+
+tc358743.c:
+ wget $(SRC_URL)/tc358743.c