aboutsummarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorAntony Kellermann2018-01-17 23:31:00 -0500
committerAntony Kellermann2018-01-17 23:31:00 -0500
commit1e7a5c2156fc56f4d77104489135bfaa6736eb0d (patch)
treedbaa52193aa240efc76b50af9ede91e4040e5e68 /Makefile
downloadaur-1e7a5c2156fc56f4d77104489135bfaa6736eb0d.tar.gz
Initial commit
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..e6b5cafb3032
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,24 @@
+CC = gcc
+CFLAGS = -g -Wall --std=c99
+OBJECTS = main.o iex.o portfolio.o
+LIBS = -lcurl
+BIN = tick
+DESTDIR = /usr
+
+$(BIN): $(OBJECTS)
+ $(CC) $(CFLAGS) $(LIBS) -o $(BIN) $(OBJECTS)
+ -gzip $(BIN).1
+install: $(BIN)
+ install -Dm755 $(BIN) $(DESTDIR)/bin/$(BIN)
+ install -Dm644 LICENSE $(DESTDIR)/share/licenses/$(BIN)/LICENSE
+ install -Dm644 $(BIN).1.gz $(DESTDIR)/share/man/man1/$(BIN).1.gz
+uninstall:
+ -rm $(DESTDIR)/bin/$(BIN)
+ -rm $(DESTDIR)/share/licenses/$(BIN)/LICENSE
+ -rm $(DESTDIR)/share/man/man1/$(BIN).1.gz
+clean:
+ -rm $(BIN) $(OBJECTS)
+ -gunzip $(BIN).1.gz
+pkgclean:
+ -rm -r $(BIN) pkg/ src/ *.xz
+.PHONY: install uninstall