aboutsummarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorAntony Kellermann2018-02-19 10:57:39 -0500
committerAntony Kellermann2018-02-19 10:57:39 -0500
commitae1752968409eede9953be79e69fcf718244c3f3 (patch)
tree02575771a9596377fae0188b31749e90aed57150 /Makefile
parentb6f37b4fc1d509cf4052084640bd0db30413823c (diff)
downloadaur-ae1752968409eede9953be79e69fcf718244c3f3.tar.gz
Updated documentation and added ncurses dependency
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index ffb7da6f136d..43e769318fe6 100644
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,7 @@
CC = gcc
-CFLAGS = -g -Wall --std=c99 -D_FORTIFY_SOURCE=2 -O2
-OBJECTS = main.o api.o portfolio.o
-LIBS = -lcurl -ljson-c -lm
+CFLAGS = -g -Wall --std=c99 -D_FORTIFY_SOURCE=2 -O2 -Wshadow -Wpointer-arith
+OBJECTS = main.o api.o portfolio.o rc4.o
+LIBS = -lcurl -ljson-c -lm -lncurses
BIN = tick
DESTDIR = /usr