summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorGötz Christ2021-10-03 15:19:04 -0500
committerGötz Christ2021-10-03 15:53:26 -0500
commit1453483e586195e5008c514d028784a5c7f6218d (patch)
treeef3aaabd00d024615e272eeec1e2180bb3ce62c4 /Makefile
parent93fcd4d7076d80a9aaaa3a86c536cac26fe2df60 (diff)
downloadaur-1453483e586195e5008c514d028784a5c7f6218d.tar.gz
Use Tremulous GrangerHub 1.3.0-alpha.0.14
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 86f41ce1bff2..6afe78a69228 100644
--- a/Makefile
+++ b/Makefile
@@ -16,7 +16,7 @@ srcinfo:
.PHONY: makepkg
makepkg:
- makepkg -s
+ makepkg --syncdeps --force
.PHONY: build
build: geninteg srcinfo makepkg
@@ -29,7 +29,7 @@ git_add:
git add PKGBUILD .SRCINFO Makefile
.PHONY: git_commit
-git_commit: VERSION = "$(shell grep pkgver .SRCINFO | cut -d '=' -f 2 | tr -d '[:space:]')"
+git_commit: VERSION = "$(shell grep pkgver .SRCINFO | cut -d '=' -f 2 | xargs)"
git_commit: GIT_STATUS = "$(shell git status --porcelain)"
git_commit:
[ -n ${GIT_STATUS} ] && git commit -m "Update to ${VERSION}"
@@ -37,3 +37,17 @@ git_commit:
.PHONY: install
install:
makepkg --repackage --install --force
+
+.PHONY: open
+open: URL = "$(shell grep url .SRCINFO | cut -d '=' -f 2 | xargs)"
+open:
+ xdg-open $(URL)
+
+.PHONY: run
+run: NAME = "$(shell grep -m 1 _name PKGBUILD | cut -d '=' -f 2 | xargs)"
+run:
+ env $(NAME)
+
+.PHONY: test
+test:
+ make run