summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorJonas Bögle2021-12-02 18:13:15 +0100
committerJonas Bögle2021-12-02 18:13:15 +0100
commitebd312dab905e5e3a158f7925ca069b915a88860 (patch)
tree3696b285e8cd6b596104d00fdcde0f31094efe92 /Makefile
parenteccaaea3aca60fd16e8891ef8a126d8ab619c8e7 (diff)
downloadaur-ebd312dab905e5e3a158f7925ca069b915a88860.tar.gz
Remove file permission workarounds
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 20fb92247502..626e7603b062 100644
--- a/Makefile
+++ b/Makefile
@@ -2,10 +2,14 @@
# This will update the checksums and build the package
all: updateinfo
makepkg -sr
+# Check if any files are world writable
+ find pkg/typora -type f -perm -o+w -printf "WARNING: '%p' has o+w set\n"
# This will do the same as all, but will install it to the local system as well
install: updateinfo
makepkg -sri
+# Check if any files are world writable
+ find pkg/typora -type f -perm -o+w -printf "WARNING: '%p' has o+w set\n"
# This will update the checksums and .SRCINFO
updateinfo: