summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorJonas Bögle2021-09-20 15:52:26 +0200
committerJonas Bögle2021-09-20 15:52:26 +0200
commitf7cca3366c085b297004508bea0cf18527531c50 (patch)
tree710e70fc1b193c54399908b59bed38e6a8c15c02 /Makefile
parente760a7b71d0c6c93bce8efd82be47b940079ad2c (diff)
downloadaur-f7cca3366c085b297004508bea0cf18527531c50.tar.gz
Remove option to build with systems electron
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/Makefile b/Makefile
index ca2fe4f15c1a..e349d9b0345a 100644
--- a/Makefile
+++ b/Makefile
@@ -1,18 +1,16 @@
# This will update the checksums and build the package
-all:
- updpkgsums
- makepkg --printsrcinfo > .SRCINFO
+all: updateinfo
makepkg -sr
# This will do the same as all, but will install it to the local system as well
-install:
- updpkgsums
- makepkg --printsrcinfo > .SRCINFO
+install: updateinfo
makepkg -sri
-system:
- ELECTRON=electron makepkg -sr
+# This will update the checksums and .SRCINFO
+updateinfo:
+ updpkgsums
+ makepkg --printsrcinfo > .SRCINFO
# This will update PKGBUILD with the latest version and build the package
update:
@@ -26,10 +24,9 @@ versions:
# This will remove the files downloaded and created in the build process
clean:
- rm -rf pkg src typora_*.deb typora-*.pkg.tar
+ rm -rf pkg src typora_*.deb typora-*.pkg.*
publish:
git add .
git commit -m "Update to version $(shell $(MAKE) versions | tail -n 1)"
git push
- git push aur master