summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorGötz2023-07-05 09:54:52 -0500
committerGötz2023-07-05 09:54:52 -0500
commit9c71478ad09c6e36c999899fad91d0eea7161007 (patch)
treeb79e56c59bb45803005ce7c01d20cda2b88be843 /Makefile
parent6adeb676d13da151049c05b1d42a0977db20cebf (diff)
downloadaur-9c71478ad09c6e36c999899fad91d0eea7161007.tar.gz
Update to 5.27.6
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile18
1 files changed, 15 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 8de6b1d0dc69..6073b72eb45d 100644
--- a/Makefile
+++ b/Makefile
@@ -1,3 +1,9 @@
+.SHELL = /usr/bin/env bash
+
+NAME = "$(shell grep -m 1 pkgname .SRCINFO | cut -d '=' -f 2 | xargs)"
+URL = "$(shell grep url .SRCINFO | cut -d '=' -f 2 | xargs)"
+VERSION = "$(shell grep pkgver .SRCINFO | cut -d '=' -f 2 | xargs)"
+
.PHONY: all
all: build git install
@@ -16,7 +22,7 @@ srcinfo:
.PHONY: makepkg
makepkg:
- makepkg -s
+ makepkg --syncdeps --force
.PHONY: build
build: geninteg srcinfo makepkg
@@ -29,7 +35,6 @@ git_add:
git add PKGBUILD .SRCINFO Makefile
.PHONY: git_commit
-git_commit: VERSION = "$(shell grep pkgver .SRCINFO | cut -d '=' -f 2 | xargs)"
git_commit: GIT_STATUS = "$(shell git status --porcelain)"
git_commit:
[ -n ${GIT_STATUS} ] && git commit -m "Update to ${VERSION}"
@@ -39,6 +44,13 @@ install:
makepkg --repackage --install --force
.PHONY: open
-open: URL = "$(shell grep url .SRCINFO | cut -d '=' -f 2 | xargs)"
open:
xdg-open $(URL)
+
+.PHONY: run
+run:
+ env $(NAME)
+
+.PHONY: test
+test:
+ env $(NAME) --version