summarylogtreecommitdiffstats
path: root/Makefile_fix.patch
diff options
context:
space:
mode:
authorTed Alff2016-12-08 10:59:11 -0500
committerTed Alff2016-12-08 10:59:11 -0500
commitfaee941f096a5c625938e02e1081857a6788ae3a (patch)
treea3e732726d93e1f95d5494439c26a00397595125 /Makefile_fix.patch
parent10bd50e6a0b9984467141d5edc46061c7e765814 (diff)
downloadaur-faee941f096a5c625938e02e1081857a6788ae3a.tar.gz
Adopted and applied Makefile fix.
Diffstat (limited to 'Makefile_fix.patch')
-rw-r--r--Makefile_fix.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile_fix.patch b/Makefile_fix.patch
new file mode 100644
index 000000000000..b33665fc73a5
--- /dev/null
+++ b/Makefile_fix.patch
@@ -0,0 +1,21 @@
+diff -Naur ./bs-2.10.orig/Makefile ./bs-2.10/Makefile
+--- ./bs-2.10.orig/Makefile 2016-12-08 10:54:14.164589590 -0500
++++ ./bs-2.10/Makefile 2016-12-08 10:54:46.243780672 -0500
+@@ -5,7 +5,7 @@
+ CC = gcc
+
+ # DESTDIR support
+-DESTDIR =
++DESTDIR =
+
+ bs: bs.c
+ $(CC) $(CFLAGS) -o bs bs.c -lncurses
+@@ -35,7 +35,7 @@
+ install -m 0644 bs.xml $(DESTDIR)/usr/share/appdata/
+
+ uninstall:
+- rm -f /usr/bin/bs /usr/share/man/man6/bs.6
++ rm -f $(DESTDIR)/usr/bin/bs $(DESTDIR)/usr/share/man/man6/bs.6
+
+ SOURCES = README COPYING NEWS control bs.c Makefile bs.xml battleship.png bs.desktop
+