summarylogtreecommitdiffstats
path: root/PKGBUILD-keyring.install
diff options
context:
space:
mode:
authorOtto Sabart2021-04-14 00:29:33 +0200
committerOtto Sabart2021-04-14 00:29:33 +0200
commit752b1fd61af6dc2a7b100228ec2b3f24b15d38d9 (patch)
tree8b01dbe9c9c9b4c27ab7a48bb0c416479aa010ba /PKGBUILD-keyring.install
downloadaur-752b1fd61af6dc2a7b100228ec2b3f24b15d38d9.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD-keyring.install')
-rw-r--r--PKGBUILD-keyring.install18
1 files changed, 18 insertions, 0 deletions
diff --git a/PKGBUILD-keyring.install b/PKGBUILD-keyring.install
new file mode 100644
index 000000000000..c915659a4943
--- /dev/null
+++ b/PKGBUILD-keyring.install
@@ -0,0 +1,18 @@
+post_upgrade() {
+ if usr/bin/pacman-key -l >/dev/null 2>&1; then
+ usr/bin/pacman-key --populate qubesos-vm
+ fi
+ release=$(echo "$1" | cut -d '.' -f 1,2)
+
+ if ! [ -h /etc/pacman.d/99-qubes-repository-${release}.conf ] ; then
+ ln -s /etc/pacman.d/99-qubes-repository-${release}.conf.disabled /etc/pacman.d/99-qubes-repository-${release}.conf
+ fi
+
+}
+
+post_install() {
+ if [ -x usr/bin/pacman-key ]; then
+ post_upgrade "$1"
+ fi
+}
+