summarylogtreecommitdiffstats
path: root/PKGBUILD.common
diff options
context:
space:
mode:
authorMichael Spradling2016-09-23 22:08:44 -0400
committerMichael Spradling2016-09-23 22:08:44 -0400
commitd7f1b22c55dc81063967423cf8763202a7916bf7 (patch)
tree730de674d7811b2f61db1b6e6a600e917cfcc69c /PKGBUILD.common
parent2d1737002eeb77a19b20f493d88bc9ab260ff85b (diff)
downloadaur-d7f1b22c55dc81063967423cf8763202a7916bf7.tar.gz
Allow bareos 15.2.4 to work with gcc 6.1.1
Removed optimizations from cflags
Diffstat (limited to 'PKGBUILD.common')
-rw-r--r--PKGBUILD.common4
1 files changed, 4 insertions, 0 deletions
diff --git a/PKGBUILD.common b/PKGBUILD.common
index b7a0c27801f9..c0ff4a05da98 100644
--- a/PKGBUILD.common
+++ b/PKGBUILD.common
@@ -63,6 +63,10 @@ prepare() {
}
build() {
+ # bareos 15.2 doesn't work with gcc 6.1.1 and newer with optimizations
+ export CFLAGS="${CFLAGS/O2/O0}"
+ export CXXFLAGS="${CXXFLAGS/O2/O0}"
+
pushd "${_pkgsrc}" &> /dev/null
QMAKE="/usr/bin/qmake-qt4" DISTNAME="debian" ./configure $_configure_args
make DESTDIR="$_instdir" install