summarylogtreecommitdiffstats
path: root/PKGBUILD.diff
diff options
context:
space:
mode:
authorChih-Hsuan Yen2021-05-31 12:17:28 +0800
committerChih-Hsuan Yen2021-05-31 12:17:28 +0800
commite47db65f61098dd6dd8303119592547949c51821 (patch)
tree5a2a8e97b8df9f705871d97b0bea7def959defc4 /PKGBUILD.diff
downloadaur-e47db65f61098dd6dd8303119592547949c51821.tar.gz
wine with IDRASSI's winscard patch
Diffstat (limited to 'PKGBUILD.diff')
-rw-r--r--PKGBUILD.diff32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD.diff b/PKGBUILD.diff
new file mode 100644
index 000000000000..b3656d8d5358
--- /dev/null
+++ b/PKGBUILD.diff
@@ -0,0 +1,32 @@
+--- PKGBUILD 2021-05-31 11:52:38.124496766 +0800
++++ PKGBUILD 2021-05-27 10:27:26.099954762 +0800
+@@ -103,7 +103,16 @@
+
+ prepare() {
+ # Allow ccache to work
+- mv $pkgname-$_pkgbasever $pkgname
++ mv wine-$_pkgbasever $pkgname
++
++ scard4wine_dir=scard4wine-yan12125/src
++ cp -v $scard4wine_dir/winscard.c $pkgname/dlls/winscard/winscard.c
++ cp -v $scard4wine_dir/winscard.spec $pkgname/dlls/winscard/winscard.spec
++ cp -v $scard4wine_dir/winscard.h $pkgname/include/winscard.h
++ cp -v $scard4wine_dir/winsmcrd.h $pkgname/include/winsmcrd.h
++ cp -v $scard4wine_dir/wine-compat56.h $pkgname/include/wine-compat.h
++
++ sed -i '/-mno-cygwin/d' $pkgname/dlls/winscard/Makefile.in
+
+ # Doesn't compile without remove these flags as of 4.10
+ export CFLAGS="${CFLAGS/-fno-plt/}"
+@@ -176,3 +185,11 @@
+ }
+
+ # vim:set ts=8 sts=2 sw=2 et:
++
++source+=("scard4wine-yan12125::git+https://git.code.sf.net/u/yan12125/scard4wine.git#commit=480dbba00d6dd555d9a36a83d024031ae8c198cc")
++sha512sums+=('SKIP')
++makedepends+=(git)
++provides=("$pkgname=$pkgver")
++conflicts=("$pkgname")
++pkgname+='-winscard'
++pkgdesc+=" (with IDRASSI's winscard patch)"