summarylogtreecommitdiffstats
path: root/PKGBUILD.testing
diff options
context:
space:
mode:
authorStelios Tsampas2023-08-30 16:06:06 +0300
committerStelios Tsampas2023-08-30 16:06:06 +0300
commitbd5f1df746e18d0a8e9c4753b898569ba9939bbe (patch)
tree4ac9debd70adf79292ba4ed6d2173fc1681cbf07 /PKGBUILD.testing
parentf3715178ed6baadccedb6fd66129613cc29262d8 (diff)
downloadaur-bd5f1df746e18d0a8e9c4753b898569ba9939bbe.tar.gz
[proton-ge-custom] Fix gst-plugins-rs failure due to llvm 16
Diffstat (limited to 'PKGBUILD.testing')
-rw-r--r--PKGBUILD.testing8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD.testing b/PKGBUILD.testing
index c4cc0ba23d2a..494c369caee7 100644
--- a/PKGBUILD.testing
+++ b/PKGBUILD.testing
@@ -6,7 +6,7 @@ _commit=ac6be1b9c3c1d402874e604b8d13c9652306b93f
pkgver=${_srctag//-/.}
_geckover=2.47.3
_monover=8.0.1
-pkgrel=5
+pkgrel=6
epoch=2
pkgdesc="Compatibility tool for Steam Play based on Wine and additional components, GloriousEggroll's custom build"
url="https://github.com/GloriousEggroll/proton-ge-custom"
@@ -149,7 +149,11 @@ prepare() {
# Explicitly set origin URL for submodules using relative paths
git remote set-url origin https://github.com/gloriouseggroll/proton-ge-custom.git
- git -c protocol.file.allow=always submodule update --init --filter=tree:0 --recursive
+ git submodule update --init --filter=tree:0 --recursive
+
+ # Fix bindgen issue with llvm 16 by updating dav1d to something newer
+ sed 's/dav1d = "0.7"/dav1d = "0.9"/g' -i gst-plugins-rs/video/dav1d/Cargo.toml
+ pushd dav1d; git checkout 1.2.1; popd
for rustlib in gst-plugins-rs media-converter; do
pushd $rustlib