summarylogtreecommitdiffstats
path: root/PKGBUILD.testing
diff options
context:
space:
mode:
authorStelios Tsampas2023-08-30 19:24:35 +0300
committerStelios Tsampas2023-08-30 19:24:35 +0300
commitfe85e8d0547dd00cbe7b9b65285d2d997310911a (patch)
tree45fe5bf9c6a5dc2f0bc69229109b4a210d2b5946 /PKGBUILD.testing
parentbd5f1df746e18d0a8e9c4753b898569ba9939bbe (diff)
downloadaur-fe85e8d0547dd00cbe7b9b65285d2d997310911a.tar.gz
[proton-ge-custom] sed libgstrsdav1d.so -> libgstdav1d.so
Diffstat (limited to 'PKGBUILD.testing')
-rw-r--r--PKGBUILD.testing7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD.testing b/PKGBUILD.testing
index 494c369caee7..27bf2378e83b 100644
--- a/PKGBUILD.testing
+++ b/PKGBUILD.testing
@@ -6,7 +6,7 @@ _commit=ac6be1b9c3c1d402874e604b8d13c9652306b93f
pkgver=${_srctag//-/.}
_geckover=2.47.3
_monover=8.0.1
-pkgrel=6
+pkgrel=7
epoch=2
pkgdesc="Compatibility tool for Steam Play based on Wine and additional components, GloriousEggroll's custom build"
url="https://github.com/GloriousEggroll/proton-ge-custom"
@@ -151,9 +151,10 @@ prepare() {
git remote set-url origin https://github.com/gloriouseggroll/proton-ge-custom.git
git submodule update --init --filter=tree:0 --recursive
- # Fix bindgen issue with llvm 16 by updating dav1d to something newer
- sed 's/dav1d = "0.7"/dav1d = "0.9"/g' -i gst-plugins-rs/video/dav1d/Cargo.toml
+ # Fix bindgen issue with llvm 16 by pulling in newer versions
pushd dav1d; git checkout 1.2.1; popd
+ pushd gst-plugins-rs; git checkout 0.11.0; popd
+ sed 's/libgstrsdav1d.so/libgstdav1d.so/g' -i Makefile.in
for rustlib in gst-plugins-rs media-converter; do
pushd $rustlib