summarylogtreecommitdiffstats
path: root/PKGBUILD.tpl
diff options
context:
space:
mode:
authorAnatoly Rugalev2022-04-14 00:07:38 +0200
committerAnatoly Rugalev2022-04-14 00:07:38 +0200
commit85632a1d533e500468a5ee23d4b7e5bc6fdfb209 (patch)
tree9372f0e5f6a7021869a8b5ccc54cee486ddbb198 /PKGBUILD.tpl
parent971853ada61084881a3c2b92a4d2232c72b2167e (diff)
downloadaur-85632a1d533e500468a5ee23d4b7e5bc6fdfb209.tar.gz
Support aarch64, i486 and i686
Diffstat (limited to 'PKGBUILD.tpl')
-rw-r--r--PKGBUILD.tpl22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD.tpl b/PKGBUILD.tpl
new file mode 100644
index 000000000000..3046da066c83
--- /dev/null
+++ b/PKGBUILD.tpl
@@ -0,0 +1,22 @@
+# Maintainer: Anatoly Rugalev <anatoly.rugalev gmail com>
+
+pkgname=kubernetes-helmfile-bin
+pkgver=${VERSION}
+pkgrel=${PKGREL}
+pkgdesc="Deploy Kubernetes Helm Charts"
+url="https://github.com/roboll/helmfile"
+license=('MIT')
+arch=('x86_64' 'aarch64' 'i486' 'i686')
+depends=('helm')
+
+source_x86_64=("helmfile_linux_${pkgver}_x86_64::https://github.com/roboll/helmfile/releases/download/v${pkgver}/helmfile_linux_amd64")
+source_i486=("helmfile_linux_${pkgver}_i486::https://github.com/roboll/helmfile/releases/download/v${pkgver}/helmfile_linux_386")
+source_i686=("helmfile_linux_${pkgver}_i686::https://github.com/roboll/helmfile/releases/download/v${pkgver}/helmfile_linux_386")
+source_aarch64=("helmfile_linux_${pkgver}_aarch64::https://github.com/roboll/helmfile/releases/download/v${pkgver}/helmfile_linux_arm64")
+
+package() {
+ cd "${srcdir}"
+ install -d "${pkgdir}/usr/bin"
+ install -m755 helmfile_linux_${pkgver}_${CARCH} "${pkgdir}/usr/bin/helmfile"
+}
+