summarylogtreecommitdiffstats
path: root/PKGBUILD.tt
diff options
context:
space:
mode:
authorAnton Leontiev2014-06-11 07:31:57 +0400
committerAnton Leontiev2015-02-15 07:48:23 +0300
commit028c85411d6f2b072cf3041771ee3d2448761553 (patch)
treec85da9acb0c407ca5c879c09ef9add73faf91d09 /PKGBUILD.tt
parentfc3bd3255631e7aa30fb785b89e3df36bc4dd222 (diff)
downloadaur-028c85411d6f2b072cf3041771ee3d2448761553.tar.gz
Updated to use template
Diffstat (limited to 'PKGBUILD.tt')
-rw-r--r--PKGBUILD.tt32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD.tt b/PKGBUILD.tt
new file mode 100644
index 000000000000..1adbe7133718
--- /dev/null
+++ b/PKGBUILD.tt
@@ -0,0 +1,32 @@
+# CPAN Name : Algorithm::Permute
+# Contributor: [% packager %]
+# Generator : CPANPLUS::Dist::Arch [% version %]
+
+pkgname=[% pkgname %]
+pkgver=[% pkgver %]
+pkgrel=[% pkgrel %]
+pkgdesc='Perl package for handy and fast permutations with object oriented interface'
+arch=('i686' 'x86_64')
+url='[% url %]'
+license=('GPL')
+depends=('perl')
+source=([% source %])
+options=(!emptydirs)
+md5sums=('[% md5sums %]')
+
+build() {
+ cd [% distdir %]
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd [% distdir %]
+ make test
+}
+
+package() {
+ cd [% distdir %]
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}