summarylogtreecommitdiffstats
path: root/PKGBUILD.tt
diff options
context:
space:
mode:
authorAnton Leontiev2014-06-11 15:04:16 +0400
committerAnton Leontiev2015-02-15 07:48:23 +0300
commit1ca5e5176c04f339cdf5699b931a44c1ee170e10 (patch)
treecf5f34ad2da6ab5963d145949197dae6b5777ce3 /PKGBUILD.tt
parenta4960e77927f9929e01e74462288b65b2da48962 (diff)
downloadaur-1ca5e5176c04f339cdf5699b931a44c1ee170e10.tar.gz
Updated to use template
Diffstat (limited to 'PKGBUILD.tt')
-rw-r--r--PKGBUILD.tt32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD.tt b/PKGBUILD.tt
new file mode 100644
index 000000000000..57809664b1ba
--- /dev/null
+++ b/PKGBUILD.tt
@@ -0,0 +1,32 @@
+# CPAN Name : Cache::Simple::TimedExpiry
+# Contributor: [% packager %]
+# Generator : CPANPLUS::Dist::Arch [% version %]
+
+pkgname=[% pkgname %]
+pkgver=[% pkgver %]
+pkgrel=[% pkgrel %]
+pkgdesc='Perl package providing a lightweight cache with timed expiration'
+arch=('any')
+url='[% url %]'
+license=('PerlArtistic' 'GPL')
+depends=('perl')
+source=([% source %])
+options=(!emptydirs)
+md5sums=('[% md5sums %]')
+
+build() {
+ cd [% distdir %]
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd [% distdir %]
+ make test
+}
+
+package() {
+ cd [% distdir %]
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}