summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfusion8092016-09-14 10:59:20 +1000
committerfusion8092016-09-14 10:59:20 +1000
commit7a469b6baa6c56bd821b0eddd754a5dceb993c9a (patch)
tree8887572d028b2913f2d977b5ee1ca90ae50e6687 /PKGBUILD
parent306889eaa017d99790346793c37bccf3eb8bfe7e (diff)
downloadaur-7a469b6baa6c56bd821b0eddd754a5dceb993c9a.tar.gz
Updating
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 20 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8a64b68ab54a..98cb2555e9c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,12 @@
# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
# Contributor: t3ddy <t3ddy1988 "at" gmail {dot} com>
# Contributor: Adrián Chaves Fernández (Gallaecio) <adriyetichaves@gmail.com>
-pkgname=0ad-git
+pkgname=('0ad-git' '0ad-data-git')
_pkgname=0ad
pkgver=18069
pkgrel=1
-pkgdesc="Cross-platform, 3D and historically-based real-time strategy game — built from git source tree. WARNING: the 0ad git repo is 2.7 GB in size!"
arch=('i686' 'x86_64')
url="http://play0ad.com/"
-conflicts=('0ad')
-provides=('0ad')
license=('GPL2' 'CCPL')
depends=('binutils' 'boost-libs' 'curl' 'enet' 'libogg' 'libpng' 'libvorbis'
'libxml2' 'openal' 'sdl2' 'wxgtk' 'zlib' 'libgl' '0ad-data' 'glu'
@@ -28,6 +25,7 @@ pkgver() {
prepare() {
cd "$srcdir/${_pkgname}"
sed -i "s/env python/env python2/g" libraries/source/cxxtest-4.4/bin/cxxtestgen
+# patch -Np1 -i "$srcdir/tmpfixgcsegfault3.patch"
}
build() {
@@ -40,23 +38,35 @@ build() {
--libdir=/usr/lib/0ad \
--datadir=/usr/share/${pkgname}/data
- cd "$srcdir/${_pkgname}/build/workspaces/gcc"
+ cd "$srcdir/${_pkgname}/libraries/source/fcollada/src"
+ make
+ cd "$srcdir/${_pkgname}/build/workspaces/gcc"
make
}
-package() {
- install -d "${pkgdir}"/usr/{bin,lib/${_pkgname},share/"${_pkgname}"/data}
+package_0ad-git() {
+ pkgdesc="Cross-platform, 3D and historically-based real-time strategy game — built from git source tree. WARNING: the 0ad git repo is 2.7 GB in size!"
+ conflicts=('0ad')
+ provides=('0ad')
+
+ install -d "${pkgdir}"/usr/{bin,lib/${_pkgname}}
cd "$srcdir/${_pkgname}"
install -Dm755 binaries/system/pyrogenesis "${pkgdir}/usr/bin"
install -Dm755 binaries/system/*.so "${pkgdir}/usr/lib/${_pkgname}"
-
- cp -r binaries/data/l10n/ ${pkgdir}/usr/share/${_pkgname}/data/
-
install -Dm755 build/resources/${_pkgname}.sh "${pkgdir}/usr/bin/${_pkgname}"
install -Dm644 build/resources/${_pkgname}.desktop \
"${pkgdir}/usr/share/applications/${_pkgname}.desktop"
install -Dm644 build/resources/${_pkgname}.png \
"${pkgdir}/usr/share/pixmaps/${_pkgname}.png"
}
+
+package_0ad-data-git() {
+ pkgdesc="Data package for 0ad built from source code. WARNING: the 0ad git repo is 2.7 GB in size!"
+ conflicts=('0ad-data')
+ provides=('0ad-data')
+
+ mkdir -p ${pkgdir}/usr/share/${_pkgname}
+ cp -r ${srcdir}/${_pkgname}/binaries/data ${pkgdir}/usr/share/${_pkgname}
+}