summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorArchLinux Release Bot2021-07-06 18:08:46 +0000
committerArchLinux Release Bot2021-07-06 18:08:46 +0000
commit4fa8d3c2688b9023dd3eb7e4af14f3c9a36e5eed (patch)
tree143dc71f447511e796bd7a151d498e682ab2b69f /PKGBUILD
parentcea8795e7ae417d2e15d63e3a266597075f43a94 (diff)
downloadaur-4fa8d3c2688b9023dd3eb7e4af14f3c9a36e5eed.tar.gz
upgpkg: 1password 8.1.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 17 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9c483c4361e0..26de4f88cedd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,47 +1,49 @@
pkgname=1password
-_tarver=8.0.34
-_tar="${pkgname}-${_tarver}.x64.tar.gz"
+_tarver=8.1.1
+_tar="1password-${_tarver}.x64.tar.gz"
pkgver=${_tarver//-/_}
-pkgrel=1
+pkgrel=4
+conflicts=('1password-beta' '1password-beta-bin')
pkgdesc="Password manager and secure wallet"
arch=('x86_64')
url='https://1password.com'
license=('LicenseRef-1Password-Proprietary')
-depends=('hicolor-icon-theme')
options=(!strip)
-install="${pkgname}.install"
-source=(https://downloads.1password.com/linux/tar/stable/x86_64/${_tar}{,.sig})
-sha256sums=('b0f2e0e31a9d6ae3ce2a2ba97736876b13083bc14bdf6eef515bbf5d760ae156'
- '6f9e0001fd6c53f1eda4d5399a39c756c5d134aeeb686d0b563d12dad0300681'
+install="1password.install"
+source=(https://downloads.1password.com/linux/tar/stable/${CARCH}/${_tar}{,.sig})
+sha256sums=('be72b6fa9652b6724b4fa5232661bba67e3cddbf2ac50060be2ff724a1d36978'
+ 'e3586dfc1f985a7d6bcb05d08c8071281d8802db07ee8e6d10e7cc195f4c3b90'
)
validpgpkeys=('3FEF9748469ADBE15DA7CA80AC2D62742012EA22')
package() {
+ depends=('hicolor-icon-theme' 'libgtk-3.so=0' 'nss')
+
# Go to source directory
- cd "${pkgname}-${_tarver}.x64"
+ cd "1password-${_tarver}.x64"
# Install icons
resolutions=(32x32 64x64 256x256 512x512)
for resolution in "${resolutions[@]}"
do
- install -Dm0644 "resources/icons/hicolor/${resolution}/apps/${pkgname}.png" \
- "${pkgdir}/usr/share/icons/hicolor/${resolution}/apps/${pkgname}.png"
+ install -Dm0644 "resources/icons/hicolor/${resolution}/apps/1password.png" \
+ "${pkgdir}/usr/share/icons/hicolor/${resolution}/apps/1password.png"
done
# Install desktop file
- install -Dm0644 resources/${pkgname}.desktop -t "${pkgdir}"/usr/share/applications/
+ install -Dm0644 resources/1password.desktop -t "${pkgdir}"/usr/share/applications/
# Install system unlock PolKit policy file
install -Dm0644 com.1password.1Password.policy -t "${pkgdir}"/usr/share/polkit-1/actions/
# Install examples
- install -Dm0644 resources/custom_allowed_browsers -t "${pkgdir}"/usr/share/doc/${pkgname}/examples/
+ install -Dm0644 resources/custom_allowed_browsers -t "${pkgdir}"/usr/share/doc/1password/examples/
# Move package contents to /opt/1Password
cd "${srcdir}"
install -dm0755 "${pkgdir}"/opt
- mv "${pkgname}-${_tarver}.x64" "${pkgdir}/opt/1Password"
+ mv "1password-${_tarver}.x64" "${pkgdir}/opt/1Password"
# Symlink /usr/bin executable to opt
install -dm0755 "${pkgdir}"/usr/bin
- ln -s /opt/1Password/${pkgname} "${pkgdir}"/usr/bin/${pkgname}
+ ln -s /opt/1Password/1password "${pkgdir}"/usr/bin/1password
}