summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbl00dy18372020-10-10 14:18:26 +0200
committerbl00dy18372020-10-10 14:18:26 +0200
commit707692501b913c9c2fbfb647920bcb419b99f30c (patch)
treee9db3ac4370d5bd9f83f36eba991969b5f87ef70 /PKGBUILD
downloadaur-707692501b913c9c2fbfb647920bcb419b99f30c.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aed74019a626
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: <reg-archlinux AT klein DOT tuxli DOT ch>
+
+_pkgname=2048.cpp
+pkgname=${_pkgname}-git
+pkgver=r362.50bd8a7
+pkgrel=1
+pkgdesc="Fully featured terminal version of the game "2048" written in C++ "
+arch=('any')
+url="https://github.com/plibither8/2048.cpp"
+license=('MIT')
+makedepends=('git' 'cmake')
+source=("git+https://github.com/plibither8/2048.cpp.git")
+sha1sums=('SKIP')
+
+conflicts=("2048.c" "2048.c-git" "2048-cli-git" "2048-curses" "2048-rs")
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ cmake .
+ cmake --build .
+}
+
+package() {
+ install "${srcdir}/${_pkgname}/2048" -D "${pkgdir}/usr/bin/2048"
+}
+
+