summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrew Sun2018-10-13 22:06:41 -0400
committerAndrew Sun2018-10-13 22:06:41 -0400
commitc0cb863d1d9bcc22163356607e56d8e8632e8c72 (patch)
treeef10e285c169fa99ac9f6932d8de769a8426a6b0 /PKGBUILD
downloadaur-c0cb863d1d9bcc22163356607e56d8e8632e8c72.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..53a16118d02c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Andrew Sun <adsun701@gmail.com>
+
+pkgname=2ping
+pkgver=4.2
+pkgrel=1
+pkgdesc="a bi-directional ping utility"
+arch=('any')
+url="https://www.finnie.org/software/2ping/"
+license=("GPL2")
+depends=("python" "python-dnspython" "python-netifaces" "python-pycryptodome")
+makedepends=("python-setuptools")
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/rfinnie/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('121cebb25c7bbd54ff94097188f5b3580bcf9ecd413ea876a4fef4aecdb35a73')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python3 setup.py build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python3 setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/2ping/COPYING"
+}