summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrew Sun2020-06-09 08:39:20 -0400
committerAndrew Sun2020-06-09 08:39:20 -0400
commitc4865a08e5f26061750b580cf1111e67c936f3b3 (patch)
tree5715c7fcdae49ee1f2ec634284fa4faa53b34aa8 /PKGBUILD
parent87db9b276b9d5eb33cc2276239b89b2fb6f3310c (diff)
downloadaur-c4865a08e5f26061750b580cf1111e67c936f3b3.tar.gz
4.4.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fecc4b8e437f..e22e483c9c90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
# Maintainer: Andrew Sun <adsun701 at gmail dot com>
pkgname=2ping
-pkgver=4.4
+pkgver=4.4.1
pkgrel=1
pkgdesc="a bi-directional ping utility"
arch=('any')
url="https://www.finnie.org/software/2ping/"
license=("GPL2")
-depends=("python" "python-dnspython" "python-netifaces" "python-pycryptodome")
-makedepends=("python-setuptools")
+depends=('python-dnspython' 'python-netifaces' 'python-pycryptodome')
+makedepends=('python-setuptools')
+optdepends=('bash-completion: for bash auto-completion')
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/rfinnie/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('a51ab4c4f8cd8eccde62244c70b89b09e995604ccfaa117a305052d1be5388e0')
+sha256sums=('d075dbf7cbce259a1f4021a979aeeddde2574437ce5e74b444d7282de462039e')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -21,5 +22,8 @@ package() {
cd "${srcdir}/${pkgname}-${pkgver}"
python3 setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 2ping.service "${pkgdir}/usr/lib/systemd/system/2ping.service"
+ install -Dm644 2ping.bash_completion "${pkgdir}/usr/share/bash-completion/completions/2ping"
+
install -Dm644 COPYING "${pkgdir}/usr/share/licenses/2ping/COPYING"
}