summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrew Sun2021-03-20 21:18:38 -0400
committerAndrew Sun2021-03-20 21:18:38 -0400
commitef6971f4dd3369ab8391739ea88757aaef9a67de (patch)
treeff30a02eea4a4349ba966a3e070b6388218dc13a /PKGBUILD
parente8819f23b7542240b2f733e36323f6c9f749ef6b (diff)
downloadaur-ef6971f4dd3369ab8391739ea88757aaef9a67de.tar.gz
4.5.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c274357a3801..e66c9a040dec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,28 @@
# Maintainer: Andrew Sun <adsun701 at gmail dot com>
pkgname=2ping
-pkgver=4.5
-pkgrel=2
+pkgver=4.5.1
+pkgrel=1
pkgdesc="a bi-directional ping utility"
arch=('any')
url="https://www.finnie.org/software/2ping/"
license=("GPL2")
depends=('python-dnspython' 'python-netifaces' 'python-pycryptodome'
- 'python-pycryptodomex' 'python-distro')
+ 'python-pycryptodomex' 'python-distro' 'python-systemd')
makedepends=('python-setuptools')
optdepends=('bash-completion: for bash auto-completion')
source=("https://www.finnie.org/software/${pkgname}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('867009928bf767d36279f90ff8f891855804c0004849f9554ac77fcd7f0fdb7b')
+sha256sums=('b56beb1b7da1ab23faa6d28462bcab9785021011b3df004d5d3c8a97ed7d70d8')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- python3 setup.py build
+ python setup.py build
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
- python3 setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
-
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
install -Dm644 2ping.service "${pkgdir}/usr/lib/systemd/system/2ping.service"
install -Dm644 2ping.bash_completion "${pkgdir}/usr/share/bash-completion/completions/2ping"
-
- install -Dm644 COPYING "${pkgdir}/usr/share/licenses/2ping/COPYING"
+ install -Dm644 COPYING.md "${pkgdir}/usr/share/licenses/2ping/COPYING.md"
}