summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJavier Torres2016-05-27 20:19:15 +0200
committerJavier Torres2016-05-27 20:19:15 +0200
commit053ece9fb075d55fce9ade310f55ac48e66db3f0 (patch)
tree494c42668e448c8419d8b6d8ac2a8be56b6b6f32 /PKGBUILD
parent750e528c4105916fafea802effdddf771b1d42d1 (diff)
downloadaur-053ece9fb075d55fce9ade310f55ac48e66db3f0.tar.gz
Update to 1.3.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 13 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2c7e00a8ee72..d8be1c8b8da0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
-# Maintainer: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
+# Maintainer: Javier Torres <javitonino [at] gmail [dot] com>
+# Contributor: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
BUILD_SELINUX=false
pkgname=389-ds-base
-pkgver=1.3.4.1
+pkgver=1.3.5.4
pkgrel=1
pkgdesc="389 Directory Server (base)"
arch=(i686 x86_64)
url="http://port389.org/"
license=(GPL)
depends=(db cyrus-sasl cyrus-sasl-gssapi icu lm_sensors net-snmp nspr nss
- openldap openssl pcre perl-mozldap perl-netaddr-ip perl-socket svrcore
+ openldap openssl pcre perl-mozldap perl-netaddr-ip perl-socket 'svrcore>=4.1.2'
tcp_wrappers zlib)
if [[ "${BUILD_SELINUX}" = "true" ]]; then
depends+=(selinux-usr-policycoreutils)
@@ -23,8 +24,10 @@ backup=(etc/default/dirsrv
etc/dirsrv/config/template-initconfig)
options=(!libtool)
install=${pkgname}.install
-source=("http://www.port389.org/binaries/${pkgname}-${pkgver}.tar.bz2")
-sha512sums=('fb160600338d8ed2fe6f0ad0c724ad208347fb684981ce5839b57b1b3d2c42664fa2e803e826f1b1178a881dc0bf557a2c6e5a729e0208a0bb3ede571781bdbf')
+source=("http://www.port389.org/binaries/${pkgname}-${pkgver}.tar.bz2"
+ "pkg-config.patch")
+sha512sums=('0cf3a1e403bc6d417525f908263d59689bbee1db887c5ba552fdae28252a59c37ee8e47ec29c48eb18fc1384652b94667f5768df87602f4c37b86d7ef0df284e'
+ 'd20a7387c509983fa68ff22d5cd363e41d3c91ebd9232921edcc6c4b61a960a2cfd85e6f76152c39abf6a3c75f1617b8e94492fe2fdc3538038bd14c05bbac75')
build() {
cd "${pkgname}-${pkgver}"
@@ -38,11 +41,16 @@ build() {
export USE_64=1
fi
+ patch -p1 < "${srcdir}/pkg-config.patch"
+ autoreconf
+
./configure \
--prefix=/usr \
--sysconfdir=/etc \
--sbindir=/usr/bin \
+ --localstatedir=/var \
--with-tmpfiles-d=/usr/lib/tmpfiles.d \
+ --with-systemd \
--with-systemdsystemunitdir=/usr/lib/systemd/system \
--with-systemdsystemconfdir=/etc/systemd/system \
--with-systemdgroupname=${pkgname}.target \