summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Mullins2016-01-18 20:06:30 -0500
committerChristopher Mullins2016-01-18 20:06:30 -0500
commitcf090d671f4ae8fcc5267c0c015467449cc3ae8c (patch)
tree4556c1cefec988d3960f834adf09246fb96f21c3 /PKGBUILD
parent521f17182caf5e3c5d0f52c5495d3468e0853e4e (diff)
downloadaur-cf090d671f4ae8fcc5267c0c015467449cc3ae8c.tar.gz
Add desktop file and icon.
h/t Eugene for adding these.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 13 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aa9834a4390f..012976ac5f30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,27 @@
-# Maintainer: Tomáš Mládek <tmladek [on] inventati [bop] org>
-# Contributor: Chris <christopher.r.mullisn g-mail>
+# Maintainer: Chris <christopher.r.mullins g-mail>
+# Contributor: Tomáš Mládek <tmladek [on] inventati [bop] org>
+# Contributor: Eugene Dvoretsky <radioxoma at g-mail>
pkgname=3dslicer
pkgver=4.5.0
-pkgrel=2
+pkgrel=3
pkgdesc="A free, open source software package for image analysis and scientific visualization."
url="http://slicer.org"
arch=('x86_64')
license=('BSD')
depends=('glu')
-source=("Slicer-$pkgver-linux-amd64.tar.gz::http://download.slicer.org/bitstream/461634")
-sha512sums=('c41dbf0248a07fceee1040cf58a7f6b08e7bec7cc306138663d736e6fd2a02545828655d44df346000805102ad4f1947e5d1e301371a652984545079ae511226')
+source=("Slicer-$pkgver-linux-amd64.tar.gz::http://download.slicer.org/bitstream/461634"
+ "3dslicer.png::https://www.slicer.org/slicerWiki/images/7/71/3DSlicerLogo-DesktopIcon-128x128.png"
+ "3dslicer.desktop")
+sha512sums=('c41dbf0248a07fceee1040cf58a7f6b08e7bec7cc306138663d736e6fd2a02545828655d44df346000805102ad4f1947e5d1e301371a652984545079ae511226'
+ 'f3f8a3de8b774d2a968e293471f92d23af5f56a2f025f0ad49035802d94f35a6578c8a161e9f9ed3c2f63beb337bea6952f93e0651ecc6a34c20fd8171e4d087'
+ '0a6c00eeb4bac3862c0cac63b20d05068deb2f46540ba5f73bad9f74697d62022b952641562762049fb0473eed9cd816e39388c440fbdef03518609825834194')
package() {
install -d "$pkgdir"/opt/3dslicer "$pkgdir"/usr/bin
mv "$srcdir/Slicer-$pkgver-1-linux-amd64/"* "$pkgdir/opt/3dslicer"
ln -s /opt/3dslicer/Slicer "$pkgdir/usr/bin"
+ install -Dm644 "${srcdir}/3dslicer.desktop" "${pkgdir}/usr/share/applications/3dslicer.desktop"
+ # https://www.slicer.org/slicerWiki/index.php/Slicer3:Slicer3Brand
+ install -Dm644 "${srcdir}/3dslicer.png" "${pkgdir}/usr/share/pixmaps/3dslicer.png"
}