summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuke Johnston2016-12-18 13:47:05 -0800
committerLuke Johnston2016-12-18 13:50:26 -0800
commita6c6957570760896b1748eb6795d5afb841b69ab (patch)
tree58acef8fbc8d742d699612fcba87fbfa480ded8e /PKGBUILD
downloadaur-3mf2stl.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..129fccd88be6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Luke Johnston <lukejohnston at outlook dot com>
+pkgname="3mf2stl"
+pkgver=1.0
+pkgrel=1
+pkgdesc="Convert 3mf files to stl"
+depends=("gcc-libs" "libzip")
+arch=("x86_64")
+url="https://github.com/lemgandi/3mf2stl"
+source=("git+https://github.com/lemgandi/3mf2stl.git")
+license=("GPL3")
+provides=("3mf2stl")
+md5sums=('SKIP')
+
+build() {
+ cd "${srcdir}/3mf2stl"
+ make
+}
+
+package() {
+ cd "${srcdir}/3mf2stl"
+ mkdir -p "${pkgdir}/usr/bin"
+ cp 3mf2stl "${pkgdir}/usr/bin"
+}