summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorManish Munikar2015-07-04 19:42:33 +0545
committerManish Munikar2015-07-04 19:42:33 +0545
commit54fae1d465eb145a996abd2a8f09990d823f0a33 (patch)
tree37f6e19894c9ddcddf679ca7be045039407ec709 /PKGBUILD
downloadaur-54fae1d465eb145a996abd2a8f09990d823f0a33.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..01d5c3e56eb0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Manish Munikar <munikarmanish at gmail dot com>
+
+pkgname=8085-simulator
+pkgver=2.0
+pkgrel=1
+pkgdesc="Jubin's 8085 Simulator with Training Kit"
+arch=('any')
+url="https://8085simulator.codeplex.com"
+license=('GPL2')
+depends=('java-runtime')
+install=
+changelog=
+source=("${pkgname}-${pkgver}.jar::http://download-codeplex.sec.s-msft.com/Download/Release?ProjectName=8085simulator&DownloadId=87364&FileTime=130460912818130000&Build=21024"
+ "${pkgname}"
+ "${pkgname}.desktop")
+noextract=("8085-simulator-2.0.jar")
+sha256sums=("9ca0323f74e9cf5db13476a65c563bcf52ebf13dceb92a1f472b6d35bf7dd01e"
+ "449c1dabed9d2a7e0689420a79975d6b6734842a91e4dfccfedbe223402ebd0a"
+ "30385a84b5f6cebd78cc7e770ce74f2a9f6271e4000dfb676da0e36f7451c0be")
+
+package() {
+ msg2 "Copying source files..."
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}.jar" "${pkgdir}/opt/${pkgname}/${pkgname}-${pkgver}.jar"
+
+ msg2 "Creating executable file..."
+ install -Dm755 "${srcdir}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+
+ msg2 "Creating desktop entry..."
+ install -Dm644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+}