summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorArpan Kapoor2016-05-10 09:50:37 +0530
committerArpan Kapoor2016-05-10 09:50:37 +0530
commit66ba29244c2a2c932fa4f136c267e713c0ffcaed (patch)
treedaca951385dc69725f4e59fda0f62c1c709a9d7d /PKGBUILD
parent2065c9ccec22dfe1032b7eec09123ff3995fd700 (diff)
downloadaur-66ba29244c2a2c932fa4f136c267e713c0ffcaed.tar.gz
Replace is_compat_task() with in_compat_syscall()
This change was introduced with commit id 5180e3e24fd3e8e7ea46fbe21e10f5ea3fb1edaa on Linus' tree.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f4b2676fac20..9c24d272e1a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,11 @@
pkgname=8188eu-dkms
_pkgname=${pkgname%-*}
pkgver=v4.3.0.8_13968
-pkgrel=3
+pkgrel=4
pkgdesc="Driver for Realtek RTL8188EUS (RTL8188EUS, RTL8188ETV) WLAN"
-arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
+arch=('any')
url="http://www.realtek.com.tw/"
-license=('GPL2')
+license=('GPL')
depends=('dkms')
install=${pkgname}.install
source=("https://dl.dropboxusercontent.com/u/27457926/${_pkgname}-${pkgver}.tar.xz"
@@ -18,6 +18,7 @@ source=("https://dl.dropboxusercontent.com/u/27457926/${_pkgname}-${pkgver}.tar.
'linux-4.0.patch'
'linux-4.2.patch'
'linux-4.3.patch'
+ 'linux-4.6.patch'
'no_debug.patch')
sha256sums=('c5604632f88ab6c68074635c73403a3f612f9f69b52af8fe9b96cf851db7a832'
'edaeafe28410017fabb742d6ccdf060a945150fb56e41084adb7b9dd66739e2b'
@@ -27,6 +28,7 @@ sha256sums=('c5604632f88ab6c68074635c73403a3f612f9f69b52af8fe9b96cf851db7a832'
'b4614962e50f86690cdb30ccde013bb480f29b13b157e8feb05a799b5776369d'
'a8621280e07d95f6aa7ae1db8a285ba512990e0af3f8f43d54bfb4d0231d2551'
'146a8d3b931861538ee36908e28d8ad774d5de0916e01511f48d84827c59cd99'
+ '936e1701b72e5ecb6b79eba722da0586cee9aabc323ddc5a69b2c07d885d1fa1'
'9b8453c15e39cf68ccc1a0d7dfb093439f89e3b2e7c40dd0fa8d0b8aa9956cdd')
prepare() {
@@ -36,6 +38,7 @@ prepare() {
patch -p1 -i "${srcdir}/linux-4.0.patch"
patch -p1 -i "${srcdir}/linux-4.2.patch"
patch -p1 -i "${srcdir}/linux-4.3.patch"
+ patch -p1 -i "${srcdir}/linux-4.6.patch"
patch -p1 -i "${srcdir}/no_debug.patch"
# Disable power saving