summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIlya Basin2018-03-28 13:14:16 +0300
committerIlya Basin2018-03-28 13:14:16 +0300
commit9e74beca53bfaa136f7c0159099309a6c06c2928 (patch)
treef8909aa70c640cc17f69fdd38cb6732f2a1b2f75 /PKGBUILD
parent3268fbf88401aca26f402f65e88a945a1e53725e (diff)
downloadaur-9e74beca53bfaa136f7c0159099309a6c06c2928.tar.gz
cross ccache
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 6 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ce571ef0f4d5..777ff3db3a27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,10 +17,16 @@ sha1sums=('280c265b789e041c02e5c97815793dfc283fb1e6')
build() {
cd $_pkgname-$pkgver
+if [ n != "$RUN_PREPARE" ]; then
+ if [ 1 = "$ccache" ]; then
+ export CC=${CC:-ccache ${_target}-gcc}
+ export CXX=${CXX:-ccache ${_target}-g++}
+ fi
unset CFLAGS CXXFLAGS
./configure --prefix=/usr/${_target} --disable-static \
--host=${_target} \
--enable-pax_emutramp
+fi
make
}